const regex = /^0+|(?:\.|(\..*?))0+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0+|(?:\\.|(\\..*?))0+$', 'gm')
const str = `00100.2300
00100
00100.0023
100.00`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);