#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/api\/ping(?=\.|\/|$)\S*"
Local $sString = "/api/ping.json" & @CRLF & _
"/api/ping" & @CRLF & _
"/api/ping/xxx/sss.json" & @CRLF & _
"/api/ping.xml" & @CRLF & _
"" & @CRLF & _
"and this should NOT match" & @CRLF & _
"" & @CRLF & _
"/api/pingpong" & @CRLF & _
"/api/ping_pong" & @CRLF & _
"/api/ping-pong"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")