re = /\/api\/ping(?=\.|\/|$)\S*/m
str = '/api/ping.json
/api/ping
/api/ping/xxx/sss.json
/api/ping.xml
and this should NOT match
/api/pingpong
/api/ping_pong
/api/ping-pong'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end