package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\A([^-]+)-([^-][^-]+)-([^-][^-]+)-([^-][^-]+)-([^-][^-]+)`)
var str = `25-41-08-30R-242`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}