$re = '/\A([^-]+)-([^-][^-]+)-([^-][^-]+)-([^-][^-]+)-([^-][^-]+)/';
$str = '25-41-08-30R-242';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);