using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=CREATE TABLE[^(]*\([^()]*)""([^""]*)""";
string input = @"CREATE TABLE ""listings"" (
""listing_id"" INTEGER UNIQUE,
""state"" TEXT,
""title"" TEXT,
""description"" TEXT,
""price"" TEXT,
""currency_code"" TEXT,
""url"" TEXT,
PRIMARY KEY(""listing_id"")";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}