import re
regex = re.compile(r"(?<=CREATE TABLE[^(]*\([^()]*)\"([^\"]*)\"", flags=re.DOTALL)
test_str = ("CREATE TABLE \"listings\" (\n"
" \"listing_id\" INTEGER UNIQUE,\n"
" \"state\" TEXT,\n"
" \"title\" TEXT,\n"
" \"description\" TEXT,\n"
" \"price\" TEXT,\n"
" \"currency_code\" TEXT,\n"
" \"url\" TEXT,\n"
" PRIMARY KEY(\"listing_id\")")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")