#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?(DEFINE)" & @CRLF & _
" (?<lowercase>(?=[^a-z]*[a-z])) # lowercase" & @CRLF & _
" (?<uppercase>(?=[^A-Z]*[A-Z])) # uppercase" & @CRLF & _
" (?<anA>A(?=B))" & @CRLF & _
" )" & @CRLF & _
" ^(?&lowercase)(.*?)((?&anA)).*"
Local $sString = "this is an A " & @CRLF & _
"A" & @CRLF & _
"ABC" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")