re = /(?(DEFINE)
(?<lowercase>(?=[^a-z]*[a-z])) # lowercase
(?<uppercase>(?=[^A-Z]*[A-Z])) # uppercase
(?<anA>A(?=B))
)
^(?&lowercase)(.*?)((?&anA)).*/mx
str = 'this is an A
A
ABC
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end