using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+)[^<>]*?>(.*?)<\/\1>";
string input = @"<div><span>text text</span></div><a href=""#"">link</a>
<div><input type=""button"" value=""click""><ul><li>item1</li><li>item2</li></ul></div>
<p><pos w=""12"">good</pos></p>
text<a href=""#"">text link</a>
<button>name</button><textarea></textarea>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}