package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b\w*oana\w*\b`)
var str = `blah OANAmama blah aOANAtata aOANAt msmsmsOANAasfasfa mOANAmsmf OANAtata OANA3 oanTy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}