re = /\b\w*oana\w*\b/i
str = 'blah OANAmama blah aOANAtata aOANAt msmsmsOANAasfasfa mOANAmsmf OANAtata OANA3 oanTy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end