package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[*?_A-Za-z0-9]|\\[\\!"#$%&'()+,.\/:;<>=@[\]^`{|}~*?-])(?:[A-Za-z0-9_]|\\[\\!"#$%&'()+,.\/:;<>=@[\]^`{|}~*?-])*(?:\*|\?+)?`)
var str = `foo\-bar
Acrobat_Reader
\"oh_my\!\"
g\+\+
9\.?
sr*
big\$money
foo\:bar
back\\slash_software
with_quoted_\~tilde
*SOFT*
8\.??
*8\.??
?hello?
\\help1??
hello?hello`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}