package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Za-z\d_@$!%*?&]{8,}`)
var str = `asdf@1234
ASDF@4567!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}