$re = '/[A-Za-z\d_@$!%*?&]{8,}/m';
$str = 'asdf@1234
ASDF@4567!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);