package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*<\/?place-holder_\d{1,2}>`)
var str = `<consumers>
<place-holder_1>
<consumer>
<val>1</val>
</consumer>
</place-holder_1>
<place-holder_10>
<consumer-info>
<val>2</val>
</consumer-info>
</place-holder_10>
</consumers>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}