$re = '/^\s*<\/?place-holder_\d{1,2}>/m';
$str = '<consumers>
<place-holder_1>
<consumer>
<val>1</val>
</consumer>
</place-holder_1>
<place-holder_10>
<consumer-info>
<val>2</val>
</consumer-info>
</place-holder_10>
</consumers>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);