using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*<MIR-\d+>.*<(?:EXP-V|ASSC-PHRASE)-\d+>.*<VACCVIRUS-PROP-\d+>.*";
string input = @"text <MIR-1> GGG-33 <EXP-V-3> text text <VACCVIRUS-PROP-1> some other.
text <MIR-1> text <ASSC-PHRASE-1> text <VACCVIRUS-PROP-1> some other <PATTERN-1> other.
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}