import re
regex = re.compile(r"\b(?=\d*[a-z])(?=[a-z]*\d)(?:[a-z]|(\d)(?!\w*\1))+\b", flags=re.MULTILINE)
test_str = ("I would like abc123 to match but not 123.\n"
"ab12s should also match\n"
"Only number-words like 1234 should not match\n"
"Words containing same numbers like ab22s should not match\n"
"234 should not match\n"
"hel1lo2haha3hoho4\n"
"hel1lo2haha3hoho3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")