package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]\d{4}(-[a-zA-Z0-9]{2})?$`)
var str = `# The CMS, who maintain these codes, describe the format as:-
# "HCPCS Level II codes (also known as alpha-numeric codes) consist of a single alphabetical letter followed by 4 numeric digits."
# (https://www.cms.gov/medicare/coding-billing/healthcare-common-procedure-system)
# NOTE: This regex will not identify HCPCS Level I codes (AKA CPT codes)
# Also, some sources say the single letter ranges only from A-V (this regex follows A-Z)
# It's not clear if the first letter must be capitalized. This regex assumes not.
# This version of the regex matches optional modifiers (ie a hyphen then 2 characters after the code)
# (https://www.aapc.com/resources/what-are-medical-coding-modifiers)
# A separate regex has been created on regex101 that ignores modifiers
# Genuine code patterns
E8015
A6410
C5278
G2102
M1221
V2623
V2756
c5278
g2102
m1221
v2623
v2756
G2102-23
E8015-OK
V2756-L5
V2756-5Q
# Should fail
EE8015
6410
E641O
[6410
_6510
g212
C52789
G2101-
G2101-2
G2101-K
G2101-OKK
G2101-123
G2101-!!
G2101-!1
G2101-()`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}