package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z]+):([a-z]+).*`)
var str = `root:x:0:0:root:/root:/bin/bash
daemon:x:1:1:daemon:/usr/sbin:/usr/sbin/nologin`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}