re = /([a-z]+):([a-z]+).*/m
str = 'root:x:0:0:root:/root:/bin/bash
daemon:x:1:1:daemon:/usr/sbin:/usr/sbin/nologin'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end