using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[ *(((['""][-\w. ]+['""]|[-\w.]+), *)*)(['""][-\w. ]+['""]|[-\w.]+) *]$";
string input = @"[ 12, kb, 67 ]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}