re = /^\[ *(((['"][-\w. ]+['"]|[-\w.]+), *)*)(['"][-\w. ]+['"]|[-\w.]+) *]$/
str = '[ 12, kb, 67 ]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end