package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\d]+:[\d]{2})(:[\d]{2})(.*)`)
var str = `12005212:50:50baadoaidjziohoufhafpuobauof`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}