$re = '/([\d]+:[\d]{2})(:[\d]{2})(.*)/m';
$str = '12005212:50:50baadoaidjziohoufhafpuobauof';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);