using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Date\s)(\S+)\h\-\h(\w+)\h\-\h(\S+)";
string input = @"johndoe@gmail.com
Passengers
Title First name Last name
Mr John Martin Doe Santos
Ms Estelle Lana Johnson Santos
Itinerary
From
Lagos (LOS), NG
To
London (LHR), GB
Date
27 - Jan - 2022
From
London (LHR), GB
To
Lagos (LOS), NG Date
21 - Feb - 2022";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}