$re = '/(?<=Date\s)(\S+)\h\-\h(\w+)\h\-\h(\S+)/m';
$str = 'johndoe@gmail.com
Passengers
Title First name Last name
Mr John Martin Doe Santos
Ms Estelle Lana Johnson Santos
Itinerary
From
Lagos (LOS), NG
To
London (LHR), GB
Date
27 - Jan - 2022
From
London (LHR), GB
To
Lagos (LOS), NG Date
21 - Feb - 2022';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);