package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/[a-z]+)?(?:\.htm)?`)
var str = `/aaa/bbbb/ccccc.htm
/xxx/yyy.htm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}