package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d[a-zA-Z]{2}){1,3}`)
var str = `1AB
1AB2CD
1AB2CD3EF
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}