$re = '/(\d[a-zA-Z]{2}){1,3}/m';
$str = '1AB
1AB2CD
1AB2CD3EF
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);