# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\D)_|_(?=\D)/./gm;t' <<< "_this_is_a_2_2_replacement_"