re = /(?<=\D)_|_(?=\D)/m
str = '_this_is_a_2_2_replacement_'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result