#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\[[^\][]*]\()https?:\/\/docs\.google\.com\/document\/d\/([^\s\\\/)]+)[^\s)]*\)"
Local $sString = "# Title" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Text text text." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Text 1 text 1 text 1, abc." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"More text" & @CRLF & _
"" & @CRLF & _
"Bullet points" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" - [abc]" & @CRLF & _
" - [bla] " & @CRLF & _
" - [cba]" & @CRLF & _
"" & @CRLF & _
"[Text](https://docs.google.com/document/d/unique-doc-id-here/edit)" & @CRLF & _
"## Title 2" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"More text:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" - A" & @CRLF & _
" - B" & @CRLF & _
" - C" & @CRLF & _
" - D" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Text text text text [url1](https://docs.google.com/document/d/2x2my-DRqfSidOsdve4m9bF_eEOJ7RqIWP7tk7PM4qEr) text." & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" **BOLD.**" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" ## Title " & @CRLF & _
" " & @CRLF & _
" Text2 text1 text3 text " & @CRLF & _
"" & @CRLF & _
"[url2](https://docs.google.com/document/d/4x2mrhsqfGSidOsdve4m9bb_wEOJ7RqsWP7tk7PMPqEb/edit#bookmark=id.mbnek2bdkj8c) text." & @CRLF & _
" " & @CRLF & _
" More text here" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" [bla](https://docs.google.com/document/d/6an7_b4Mb0OdxNZdfD3KedfvFtdf2OeGzG40ztfDhi5o9uU/edit)" & @CRLF & _
""
Local $sSubst = "$1[REPLACEMENT]$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)