$re = '/(\[[^\][]*]\()https?:\/\/docs\.google\.com\/document\/d\/([^\s\\\\\/)]+)[^\s)]*\)/m';
$str = '# Title
Text text text.
Text 1 text 1 text 1, abc.
More text
Bullet points
- [abc]
- [bla]
- [cba]
[Text](https://docs.google.com/document/d/unique-doc-id-here/edit)
## Title 2
More text:
- A
- B
- C
- D
Text text text text [url1](https://docs.google.com/document/d/2x2my-DRqfSidOsdve4m9bF_eEOJ7RqIWP7tk7PM4qEr) text.
**BOLD.**
## Title
Text2 text1 text3 text
[url2](https://docs.google.com/document/d/4x2mrhsqfGSidOsdve4m9bb_wEOJ7RqsWP7tk7PMPqEb/edit#bookmark=id.mbnek2bdkj8c) text.
More text here
[bla](https://docs.google.com/document/d/6an7_b4Mb0OdxNZdfD3KedfvFtdf2OeGzG40ztfDhi5o9uU/edit)
';
$subst = "$1[REPLACEMENT]$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;