#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)cash\s*[:,.-]?\s*(rp|idr)[.,]?\s*(\d(?:[\d\s,.]*\d)?)(?!\S)(?!\s*(?:juta|jt|m)\b)"
Local $sString = "harga cash: rp 130jt (nego alu" & @CRLF & _
"harga cash: rp 230juta (nego alu" & @CRLF & _
"harga cash: rp 330 juta (nego alu" & @CRLF & _
"harga cash: rp 430,000,000 juta (nego alu" & @CRLF & _
"harga cash: rp 530m (nego alu" & @CRLF & _
"harga cash: rp 630 (nego alu" & @CRLF & _
"harga cash: rp 730000000 (nego alu" & @CRLF & _
"harga cash: rp 830,000,000 (nego alu" & @CRLF & _
"harga cash: rp 930 000 000 (nego alu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")