# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"cash\s*[:,.-]?\s*(rp|idr)[.,]?\s*(\d(?:[\d\s,.]*\d)?)(?!\S)(?!\s*(?:juta|jt|m)\b)"
test_str = ("harga cash: rp 130jt (nego alu\n"
"harga cash: rp 230juta (nego alu\n"
"harga cash: rp 330 juta (nego alu\n"
"harga cash: rp 430,000,000 juta (nego alu\n"
"harga cash: rp 530m (nego alu\n"
"harga cash: rp 630 (nego alu\n"
"harga cash: rp 730000000 (nego alu\n"
"harga cash: rp 830,000,000 (nego alu\n"
"harga cash: rp 930 000 000 (nego alu")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.