import re
regex = re.compile(r"(([^<>()\[\]\\.,;:\s+@\"]+(\.[^<>()\[\]\\.,;:\s@\"]+)*)|(\".+\"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))", flags=re.MULTILINE)
test_str = ("mikey.martin@themartins.kiwi\n"
"mm15032@students.sacredheart.school.nz\n"
"mm15032@students..sacredheart.school.nz\n"
"mm15032students.sacredheart.school.nz\n"
"@students.sacredheart.school.nz\n"
"mm15032@@students.sacredheart.school.nz\n"
"mm15032@students.sacredheart.school.nz@\n"
".mm15032@students.sacredheart.school.nz\n"
"+mm15032@students.sacredheart.school.nz")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")