package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^.\n]+)\.([^.\n]+)(?:\.([^.\n]+))?(?:\.([^.\n]+))?\.([^.\n]+)(?:\.([^.\n]+))?(?:\.([^.\n]+))?(?:\.([^.\n]+))?(?:\.([^.\n]+))?(?:\.([^.\n]+))?`)
var str = `dog.cat.chicken.horse.whale
dog.cat.chicken.horse
dog.cat.chicken
dog.cat.chicken.horse.whale.dog.cat.chicken.horse.whale`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}