$re = '/([^.\n]+)\.([^.\n]+)(?:\.([^.\n]+))?(?:\.([^.\n]+))?\.([^.\n]+)(?:\.([^.\n]+))?(?:\.([^.\n]+))?(?:\.([^.\n]+))?(?:\.([^.\n]+))?(?:\.([^.\n]+))?/';
$str = 'dog.cat.chicken.horse.whale
dog.cat.chicken.horse
dog.cat.chicken
dog.cat.chicken.horse.whale.dog.cat.chicken.horse.whale';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);