re = /https:\/\/([a-z0-9-]+\.)*storyblok\.com(:[0-9]+)?(\\\/[^?#]*)?([?][^#]*)?/
str = 'https://a-us.storyblok.com/f/1003691/2732x2632/fca4f13694/alpaca-bw.png'
# Print the match result
str.match(re) do |match|
puts match.to_s
end