import Foundation
let pattern = ##"https://([a-z0-9-]+\.)*storyblok\.com(:[0-9]+)?(\\/[^?#]*)?([?][^#]*)?"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://a-us.storyblok.com/f/1003691/2732x2632/fca4f13694/alpaca-bw.png"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}