package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[ABCEGHJ-NPRSTVXY][0-9][ABCEGHJ-NPRSTV-Z][ ]?[0-9][ABCEGHJ-NPRSTV-Z][0-9]$`)
var str = `H1V 2M2
H1V2M2`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}