re = /^[ABCEGHJ-NPRSTVXY][0-9][ABCEGHJ-NPRSTV-Z][ ]?[0-9][ABCEGHJ-NPRSTV-Z][0-9]$/
str = 'H1V 2M2
H1V2M2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end