# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*(?<!\w)(?:CO-OP|CO|CO\.)(?!\w).*?)(?:[-\/](\s*\w+.*))?$/\1/gm;t' <<< "ABC CO-OP ELEMENTARY SCHOOL
ARMSTRONG CO-OP ELEMENTARY SCHOOL / ECOLE PRIMAIRE ARMSTRONG COOPERATIVE
"