const regex = new RegExp('^(.*(?<!\\w)(?:CO-OP|CO|CO\\.)(?!\\w).*?)(?:[-/](\\s*\\w+.*))?$', 'gm')
const str = `ABC CO-OP ELEMENTARY SCHOOL
ARMSTRONG CO-OP ELEMENTARY SCHOOL / ECOLE PRIMAIRE ARMSTRONG COOPERATIVE
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);