import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([0-9]{1,2}h)[ ]*([0-9]{1,2}min):\\s*|([0-9]{1,2}h)():\\s*|()([0-9]{1,2}min):\\s*)((?:.(?!(\\dh\\s\\d{1,2}min|\\dh|\\d{1,2}min)))+)";
final String string = "1h 30min: Title \n"
+ "- Description Line 1\n"
+ "3h: SEOND TITLE\n"
+ "- Description Line 1\n"
+ "- Description Line 2\n"
+ "- Description Line 3\n\n\n"
+ "1h 14min: Title \n"
+ "- another Great one 42min: Title - Great Movie\n"
+ "- Description Line 2\n"
+ "- Description Line 3\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}