const regex = /(([0-9]{1,2}h)[ ]*([0-9]{1,2}min):\s*|([0-9]{1,2}h)():\s*|()([0-9]{1,2}min):\s*)((?:.(?!(\dh\s\d{1,2}min|\dh|\d{1,2}min)))+)/mgs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([0-9]{1,2}h)[ ]*([0-9]{1,2}min):\\s*|([0-9]{1,2}h)():\\s*|()([0-9]{1,2}min):\\s*)((?:.(?!(\\dh\\s\\d{1,2}min|\\dh|\\d{1,2}min)))+)', 'mgs')
const str = `1h 30min: Title
- Description Line 1
3h: SEOND TITLE
- Description Line 1
- Description Line 2
- Description Line 3
1h 14min: Title
- another Great one 42min: Title - Great Movie
- Description Line 2
- Description Line 3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}