const regex = /(?<=\sAS\s).*(\[)|](?<=\sAS\s).*?(\[)|(?<=\sAS\s)?(\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\sAS\\s).*(\\[)|](?<=\\sAS\\s).*?(\\[)|(?<=\\sAS\\s)?(\\])', 'gm')
const str = `,ISNULL([Gt 01 To 02 Weeks SUM 1],0) AS [Gt 01 To 02 Weeks SUM]
,ISNULL([Gt 02 To 03 Weeks SUM 1],0) AS [Gt 02 To 03 Weeks SUM]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}