re = /(?<=\sAS\s).*(\[)|](?<=\sAS\s).*?(\[)|(?<=\sAS\s)?(\])/m
str = ',ISNULL([Gt 01 To 02 Weeks SUM 1],0) AS [Gt 01 To 02 Weeks SUM]
,ISNULL([Gt 02 To 03 Weeks SUM 1],0) AS [Gt 02 To 03 Weeks SUM]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end